Copy to Removable Drive in Explorer May Fail After Media Swap

Last reviewed: August 1, 1997
Article ID: Q171213
The information in this article applies to:
  • Microsoft Windows NT Workstation version 4.0
  • Microsoft Windows NT Server version 4.0

SYMPTOMS

In Windows NT Explorer, when you drag a folder from your hard drive to another folder on a removable drive, the files do not get copied correctly.

This problem only occurs when:

  • You have recently changed the media in the removable drive but have not forced an update in Windows NT Explorer by pressing F5.

    -and-

  • You are dragging files or folders to a folder that used to exist on the previous disk, but does not exist on the new one.

CAUSE

This problem is caused by a problem in the Explorer.exe code in Windows NT 4.0. The problem does not occur in File Manager (Winfile.exe) in Windows NT 3.51 or 4.0.

WORKAROUND

To work around this problem, force an update of the Windows NT Explorer window by pressing F5 after changing the removable media.

STATUS

Microsoft has confirmed this to be a problem in Windows NT version 4.0. A supported fix is now available, but has not been fully regression-tested and should be applied only to systems experiencing this specific problem. Unless you are severely impacted by this specific problem, Microsoft recommends that you wait for the next Service Pack that contains this fix. Contact Microsoft Technical Support for more information.


Additional query words: explorer removable media
Keywords : kbbug4.00 kbfix4.00 ntfilesys NTSrvWkst ntui kbui kbbuglist kbfixlist
Version : WinNT:4.0
Platform : winnt
Issue type : kbbug
Solution Type : kbfix


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: August 1, 1997
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.