Fault Tolerant Systems May Encounter Problems with WinNT SP3

Last reviewed: October 20, 1997
Article ID: Q171295
The information in this article applies to:
  • Microsoft Windows NT Workstation version 4.0
  • Microsoft Windows NT Server version 4.0

SYMPTOMS

With the FirstWatch program, transition failures have been observed that require the use of CLARiiON's Trespass utility. For example, the system may start in Online Primary mode, but any attempt to change into Dual mode fails. The Ha.log file contains errors that occurred while using Trespass. You may also notice that the Scsi.exe, Clarscsi.exe, and Diskcfg.exe programs do not display LUNs (logical unit numbers), which Trespass needs to access.

The CLARiiON Agent Service may report problems in the event log. The following two events messages have been logged:

  • ERROR: Opening Device: , 1:0:0.
  • Is the device configured correctly?

After these events, attempting to select the host in ArrayGuide reports the following error:

   Could not connect to the chassis, check device name in fw31a's agent
   configuration file.

ATF failures have also been observed.

CAUSE

This problem is caused by changes in the way Windows NT handles the SCSI LUN enumeration in Service Pack 3.

RESOLUTION

Perform the following steps to resolve this problem:

  1. Obtain the following fix or wait for the next Windows NT service pack.

          This fix should have the following timestamp:
    

             07/02/97  09:41 PM               34,096 Scsiport.sys (Intel)
             07/02/97  08:41 PM               53,456 Scsiport.sys (Alpha)
    
          This hotfix has been posted to the following Internet location:
    
             ftp://ftp.microsoft.com/bussys/winnt/winnt-public/fixes/usa/NT40/
             hotfixes-postSP3/scsi-fix
    
       NOTE: Service Pack 3 must be applied to Windows NT 4.0 prior to applying
       this fix.
    
    

  2. WARNING: Using Registry Editor incorrectly can cause serious, system- wide problems that may require you to reinstall Windows NT to correct them. Microsoft cannot guarantee that any problems resulting from the use of Registry Editor can be solved. Use this tool at your own risk.

    Install the new Scsiport.sys and go to the following registry key:

          HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Disk\
    

  3. Add the following new value to the above registry path to activate the new code:

          Value Name = ScanDisconnectedDevices
          Data Type = REG_DWORD
          Data = 1
    

STATUS

Microsoft has confirmed this to be a problem in Windows NT version 4.0. A supported fix is now available, but has not been fully regression-tested and should be applied only to systems experiencing this specific problem. Unless you are severely impacted by this specific problem, Microsoft recommends that you wait for the next Service Pack that contains this fix. Contact Microsoft Technical Support for more information.

MORE INFORMATION

The third-party products discussed here are manufactured by vendors independent of Microsoft; we make no warranty, implied or otherwise, regarding these products' performance or reliability.


Additional query words: 4.00 sp3 NG
Keywords : kbbug4.00.sp3 kbfix4.00 NTSrvWkst kb3rdparty kbfile
Version : WinNT:4.0
Platform : winnt
Issue type : kbbug
Solution Type : kbfix


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Last reviewed: October 20, 1997
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