Time Incorrect After Restarting Multiprocessor System

Last reviewed: January 5, 1998
Article ID: Q171790
The information in this article applies to:
  • Microsoft Windows NT Workstation versions 3.51 and 4.0
  • Microsoft Windows NT Server versions 3.51 and 4.0

SYMPTOMS

On a multiprocessor computer, if you synchronize the system time to an external time source using the Date/Time tool in Control Panel, and then restart your system, the system time will be slow by four to five seconds for every processor after the first processor.

Example:

If you set the time on a 4-processor system, the system time will be 12-15 seconds slow (3 x 4-5 seconds). Note that the time loss is not cumulative; the system will still be slow by the same amount after another restart unless the time is changed again.

CAUSE

During system initialization, the system starts by using only one processor. The system time is retrieved from the system Real Time Clock (RTC) and loaded into the system clock. Later in the initialization process, the system clock timer is halted for four to five seconds while each additional processor is configured. This halting causes a time slip from the RTC value. When the time is written, it is written to both the system clock and to the RTC.

RESOLUTION

To work around this problem, perform one of the following:

  • Synchronize the system time with an external source and restart. Determine how much time the system lost during startup, and set the system time fast by this amount. After a restart, the time should be correct. You will need to repeat this procedure every time the system time is set.
  • Run the time service provided in the resource kit. This will keep a group of servers in sync with each other.

STATUS

Microsoft has confirmed this to be a problem in Windows NT version 4.0. A supported fix is now available, but has not been fully regression- tested and should be applied only to systems experiencing this specific problem. Unless you are severely impacted by this specific problem, Microsoft recommends that you wait for the next Service Pack that contains this fix. Contact Microsoft Technical Support for more information. receive

Microsoft has confirmed this to be a problem in Windows NT version 3.51. We are researching this problem and will post new information here in the Microsoft Knowledge Base as it becomes available.

Keywords          : kbbug3.51 kbbug4.00 kbfix4.00 ntmp NTSrvWkst kbenv
Version           : WinNT:3.51,4.00
Platform          : winnt
Issue type        : kbbug
Solution Type     : kbfix


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Last reviewed: January 5, 1998
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