Missing WINS Directory Causes Missing/Corrupt Error

Last reviewed: February 20, 1998
Article ID: Q171927
The information in this article applies to:
  • Microsoft Windows NT Server versions 3.5, 3.51, and 4.0

SYMPTOMS

When your Microsoft Windows NT WINS server starts, you may receive the following error message:

   Windows Internet Naming Service

   WINS could not come up due to missing/corrupt database.

   Restore the database using WINS Manager or Winscl.exe (in the Resource
   Kit) and then restart WINS. If WINS still does not come up, start with a
   fresh copy of the database. To do this:

   1. Delete all the files in the %SystemRoot%\System32\Wins directory

      NOTE: If WINS database file (typically named wins.mdb) is not in
      the above directory, check the following registry entry for the full
      file path:

      "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Wins\
       Parameters\DbFileNm"

      Delete the .mdb file.

      NOTE: If Jet*.log is not in the above directory, check the following
      registry entry for the full file path.

      "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Wins\
      Parameters\LogFilePath"

      Delete all log files.

   2. Net start WINS.

   Please click on OK to terminate WINS.

CAUSE

This error may be caused by a missing WINS folder.

RESOLUTION

You will need to manually create the WINS folder and restart the WINS service, using the following steps:

  1. From an MS-DOS command prompt, change to the System32 folder by typing the following:

    cd %Systemroot%\System32

  2. Create the WINS folder by typing the following:

    md WINS

  3. Restart the WINS service by typing the following:

    net start WINS

MORE INFORMATION

This error normally occurs when the WINS database has actually become corrupt. While you try to troubleshoot this error, you may delete the WINS folder instead of only deleting the files in the WINS directory and the error message will reappear until the folder is recreated.

Keywords          : ntnetserv NTSrv nttcp kbnetwork
Version           : WinNT:3.51,4.0
Platform          : winnt
Issue type        : kbprb


================================================================================


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: February 20, 1998
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.