Toshiba I586 Pro 230 MHz System and the National 307 Chip

Last reviewed: December 9, 1997
Article ID: Q172122
The information in this article applies to:
  • Microsoft Windows NT Workstation version 4.0
  • Microsoft Windows NT Server version 4.0

SYMPTOMS

Windows NT may not recognize the COM2 port on a Toshiba computer.

CAUSE

Some Intel motherboards included in Toshiba computers support COM2 as an infrared (IR) device. If the COM2 port is set in the BIOS to Infrared Data Access Mode, Windows NT does not recognize it. If COM2 is set as a serial port, Windows NT recognizes it and makes it available automatically.

Windows NT fails to recognize the National 307 chip on the Intel motherboard included in some Toshiba computers. During Detection, Windows NT runs the DoesPortExist() function that reads the serial port's line control register. The COM2 port test usually returns 0x00; however, the infrared port returns 0x5C. The COM2 port is not available because Windows NT writes this returned value to the wrong registers in the device.

RESOLUTION

Perform one of the following to resolve this problem:

  • Manually install the COM2 port.

    Please refer to the manufacturer's instructions for making changes to your CMOS settings.

    1. Before Windows NT is installed, start the CMOS setup routine on the

          Toshiba PC. From the CMOS settings, change the infrared (IR) port to
          COM:2. When you install Windows NT, it will properly install the
          COM:2 port.
    

    2. If Windows NT is already installed, ensure the CMOS is set to COM2:

          (see step 1), then perform the following steps:
    

             a. Click the Start button, point to Settings, and then click
                Control Panel.
    
             b. Double-click the Ports icon, select COM2:, and then click
                Settings. Click Advanced, and then from the Settings for COM2
                Port dialog box, select 03f8 for the Base I/O Port Address and
                4 for the Interrupt Request Line. Click OK.
    
    
  • Obtain the following fix or wait for the next Windows NT service pack.

    This fix should have the following time stamp:

          08/05/97  03:28p                26,992 Ntdetect.com (Intel)
    
    

STATUS

Microsoft has confirmed this to be a problem in Windows NT version 4.0. A supported fix is now available, but has not been fully regression tested and should be applied only to systems experiencing this specific problem. Unless you are severely impacted by this specific problem, Microsoft recommends that you wait for the next Service Pack that contains this fix. Contact Microsoft Technical Support for more information.

Keywords          : kbbug4.00 kbfix4.00 nthw NTSrvWkst kbhw
Version           : WinNT:4.0
Platform          : winnt
Issue type        : kbbug
Solution Type     : kbfix


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Last reviewed: December 9, 1997
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