CSNW Connection Leak When Running 16-bit Applications

Last reviewed: November 5, 1997
Article ID: Q175877
The information in this article applies to:
  • Microsoft Windows NT Workstation version 4.0
  • Microsoft Windows NT Server version 4.0

SYMPTOMS

When you use Client Services for NetWare (CSNW) or Gateway Services for NetWare (GSNW) to connect to a NetWare server and you are running a logon script or manually invoking a 16-bit application on a NetWare server, you may receive the following error when you attempt to log back on:

   NetWare Authentication Failure

   You cannot be authenticated on <NetWare Tree and Context> due to the
   following reason: A connection to the server could not be made because
   the limit on the number of concurrent connections for this account has
   been reached.

   Do you want to select another preferred server or context?

CAUSE

The NetWare server has Limit Concurrent Connections for your user account set to 1. When the client logs off after running the 16-bit application, the connection on the NetWare server is not closed. This results in an unlicensed connection on the NetWare server. The connections are cleaned up if the user shuts down and restarts the server before logging back on.

NOTE: You can determine if a connection is unlicensed by going to the NetWare server, loading monitor, and then selecting the active connection list. Unlicensed connections will have and asterisk (*) in front of the user name.

RESOLUTION

You can work around this problem by performing any of the following:

  • Set the concurrent connections for your user account to a higher value on the NetWare server.

    -or-

  • Shut down and restart the workstation after each use.

    -or-

  • Obtain the corrected binary Winsrv.dll hotfix mentioned below or wait for the next service pack.

STATUS

Microsoft has confirmed this to be a problem in Windows NT version 4.0. A supported fix is now available, but has not been fully regression tested and should be applied only to systems experiencing this specific problem. Unless you are severely impacted by this specific problem, Microsoft recommends that you wait for the next Service Pack that contains this fix. Contact Microsoft Technical Support for more information.

MORE INFORMATION

For additional information on ensuring that the connection leak is fixed, please see the following article in the Microsoft Knowledge Base:

   ARTICLE-ID: Q174676
   TITLE : "NetWare Authentication Failure" Logging On to NetWare Server
Keywords          : kbbug4.00 kbfix4.00 kbinfo NTINTEROP ntnetserv NTPROTOCOL NTSrvWkst kbnetwork
Version           : WinNT:4.0
Platform          : winnt
Issue type        : kbbug
Solution Type     : kbfix


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Last reviewed: November 5, 1997
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