Use LoadLibraryEx When Loading Printer Drivers

Last reviewed: February 17, 1998
Article ID: Q177445
The information in this article applies to:
  • Microsoft Windows NT Workstation versions 4.0
  • Microsoft Windows NT Server versions 4.0

SYMPTOM

In specific instances under Windows NT 4.0, certain Hewlett Packard printer drivers may display a pop-up message that indicates that the print driver is not installed when it has been installed.

CAUSE

Some of the Hewlett Packard printer driver files statically link to other printer driver files that are listed as dependent files. The Windows NT spooler uses a LoadLibrary function call not the LoadLibraryEx function call. This, in combination with Hewlett Packard's print driver directory not being in the path, causes the Hewlett Packard driver not to work.

RESOLUTION

Obtain the following fix or wait for the next Windows NT service pack.

This fix should have the following timestamp(s):

   07/08/97  04:47p               144,144 Localspl.dll (Intel)
   07/08/97  04:48p                47,376 Spoolss.dll  (Intel)
   07/08/97  04:48p                38,160 Spoolss.exe  (Intel)
   07/08/97  04:48p                96,016 Winspool.drv (Intel)

   07/08/97  04:47p               259,856 Localspl.dll (Alpha)
   07/08/97  04:48p                86,800 Spoolss.dll  (Alpha)
   07/08/97  04:48p                65,808 Spoolss.exe  (Alpha)
   07/08/97  04:48p               162,576 Winspool.drv (Alpha)

STATUS

Microsoft has confirmed this to be a problem in Windows NT version 4.0. A supported fix is now available, but has not been fully regression tested and should be applied only to systems experiencing this specific problem. Unless you are severely impacted by this specific problem, Microsoft recommends that you wait for the next Service Pack that contains this fix. Contact Microsoft Technical Support for more information.


Additional query words: spoolss localspl HP print driver device point
Keywords : kbbug4.00 kbfix4.00 ntprint NTSrvWkst kbprint
Version : WinNT:4.0
Platform : winnt
Hardware : ALPHA x86
Issue type : kbbug
Solution Type : kbfix


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: February 17, 1998
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.