WD: Courier Text Printed with Underline with ATM 2.5 or Later

Last reviewed: February 5, 1998
Article ID: Q113444
The information in this article applies to:
  • Microsoft Word for Windows, versions 6.0, 6.0a, 6.0c
  • Microsoft Word for Windows 95, version 7.0
  • Microsoft Word 97 for Windows

SYMPTOMS

When you print a document that contains Courier font formatting but no underline formatting, Word for Windows may print the text with an underline. This behavior may occur even when the text appears correct (that is, not underlined) on the screen.

CAUSE

This problem may occur if you have Adobe Type Manager (ATM) version 2.5 or later installed on your computer. It does not happen with versions of ATM earlier than 2.5, and it does not happen with the ATM 2.5 packaged with WordPerfect 5.2 for Windows (this version does not include Courier fonts).

This problem frequently occurs in Word 6.0 when you open a document that was created in a different file format (such as Word 2.x for Windows, WordPerfect, or Microsoft Word for MS-DOS).

WORKAROUNDS

To work around this problem, use any of the following methods:

Method 1: If you have a Hewlett-Packard (HP) LaserJet or DeskJet printer,

          change the "Use Pre-built" setting:

          a. Double-click the ATM Control Panel in Program Manager. (Word
             can be running when you do this.) ATM Control Panel can also
             be started from Program Manager by selecting the File menu,
             choosing Run, and typing ATMCNTRL on the command line.

          b. Clear the "Use Pre-built or Resident Fonts" check box.

          c. Choose the Exit button to close the ATM Control Panel.

          d. Return to Word and reprint the document.

Method 2: If Courier font resolution differs and the result is undesirable,
          do NOT clear the "Use Pre-built or Resident Fonts" check box
          mentioned in Method 1, step 2 (that is, leave it selected), and
          do one of the following:

           - Upgrade the Courier font by contacting Adobe.

            -or-

          a. Start a text editor such as Notepad and open the ATM.INI file.

          b. In the Settings section, add the line "DeferUnder=On"
             (without the quotation marks).

          c. Save the file.

          d. Quit the text editor.

          e. Return to Word and print the document.

          NOTE: The printer can now handle underlining. In addition, the
          DeferUnder entry resolves problems with uneven underlining on
          LaserJet printers. The entry mentioned in step 2 (above) is not
          referenced in the README.TXT file supplied with ATM 2.5.

MORE INFORMATION

The following information is from the README.TXT file supplied with ATM 2.5:

   When you select the Use Pre-built or Resident Fonts option, ATM
   lets PCL printer drivers use pre-built or printer-resident fonts
   to print documents. When you clear the Use Pre-built or Resident
   Fonts check box, ATM creates characters for PCL printer drivers
   to print even when pre-built or printer-resident fonts are
   available.

   Although ATM does not require that you restart Windows after you
   change the Use Pre-built or Resident Fonts option, you might
   have to quit and restart applications for this option to take
   effect.

   If you are using Windows 3.1 with printer drivers that allow
   soft fonts to be created on-the-fly (such as the PCL drivers),
   you might want to turn this option off to speed printing.  It is
   more efficient for a printer driver to create a soft font on-
   the-fly than to download a pre-built font.  You can see if you
   have any pre-built fonts installed for your PCL printer by
   checking the printer driver's Fonts dialog box. To display the
   driver's Fonts dialog box, choose Fonts in the driver's Printer
   Setup dialog box.

The README.TXT file Adobe provides with the ATM program includes additional information on the uses and configuration of ATM for best printing results.

Adobe Type Manager (ATM) is manufactured by Adobe Systems Incorporated, a vendor independent of Microsoft. We make no warranty, expressed or implied, regarding this product's functionality. Support for Adobe Type Manager is the sole responsibility of Adobe Systems Incorporated.


Additional query words: conversion converts word95
word7 word6 transfer transferred maps mapped word ms-DOS worddos
dosword winword unwanted word8 word97
Keywords : kbfont kbprint
Version : 6.00 6.00a 6.00c 7.00 97
Platform : WINDOWS


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: February 5, 1998
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.