The information in this article applies to:
- Microsoft Word for Windows 95, versions 7.0, 7.0a
- Microsoft Word 97 for Windows
SYMPTOMS
When you use a tab-delimited text file in a mail merge or when you use the
Database command on the Insert menu, you may receive one of the following
error messages:
- External table isn't in the expected format.
-or-
- Field1|Field2|Field3|Field4|Field5 isn't a valid name.
-or-
- Syntax error in FROM clause.
-or-
- Word was unable to open the data source.
CAUSE
The ODBC Text driver installed by Microsoft Office for Windows 95 cannot
convert tab-delimited text files.
WORKAROUNDS
Method 1: Select the Method to Use When You Select the Database
To do this, use the following steps:
- To access the Open Data Source dialog box, use either of the following
procedures:
- On the Insert menu, click Database, and then click the Get Data
button.
-or-
- From the Mail Merge Helper, click the Get Data button, and then click
Open Data Source.
- Choose the database file you want to use, click the Select Method check
box to select it, and then click OK.
- From the Confirm Data Source dialog box, select Text Files, and then
click OK.
NOTE: There will be a "Text Files via ODBC" entry here if the ODBC text
converter is installed. Do not select this converter.
Method 2: Use a comma-delimited text file
Use a comma-delimited file instead of a tab-delimited text file.
NOTE: If a similar problem occurs with a comma-delimited file, try
Method 3.
Method 3: Remove the ODBC Text Driver.
This method allows Word to use its own text converter to bring in the text
document. Use the following steps to remove the ODBC Text driver:
- Quit Word and all Office programs, including the Office Shortcut Bar.
- Click the Windows Start menu, point to Settings, and click Control
Panel. Click Add/Remove Programs.
- Choose the Install/Uninstall tab.
- Select Microsoft Office. The Microsoft Office Setup program will start.
- Select Add/Remove from the Microsoft Office Setup program.
- Select the Converters, Filters, and Data Access category. Click Change
Options in the Setup dialog box.
- Click once on the Data Access category and click Change Options.
- Scroll down to the bottom of the drivers list and clear the Text Driver
check box. Click OK.
- Click OK or Continue until Setup has completed successfully. Click OK
again and restart Word.
STATUS
Microsoft is researching this problem and will post new information here in
the Microsoft Knowledge Base as it becomes available.