The information in this article applies to:
- Microsoft Word 97 for Windows
SYMPTOMS
When you print to a file using the Generic/Text Only printer driver in
Microsoft Windows NT version 4.0 or Microsoft Windows 95, the resulting
.prn file will contain garbled text. When you view the .prn file in a text
editor, all of the characters are formatted incorrectly.
CAUSE
This problem occurs when the text is formatted at 10 characters per inch,
in a font other than the Generic/Text Only printer font (Roman), and when
the default data type of the printer driver is not text.
WORKAROUND
To work around this problem, use either of the following methods.
Method 1: Change the Printer Metrics to Lay Out the Document
- Start Microsoft Word and open the document that you want to print to
a file.
- On the Tools menu, click Options.
- On the Compatibility tab, click to select Microsoft Word 97 in the
Recommended Options For box.
- On the Compatibility tab, under Options, select the "Use printer metrics
to lay out document" check box, and then click OK.
NOTE: When you select the "Use printer metrics to lay out document" check
box, the Recommended Options For box changes to Custom. This method applies
only to the current document, because "Use printer metrics to lay out
document" is a document setting only.
Method 2: Set a Printer Driver and Font Selection (Windows NT 4.0 Only)
- Click the Start button, point to Settings, and then click Printers.
- Click to select the Generic Text only printer driver icon. If this icon
does not appear, see the "Installing the Generic / Text Only Printer"
section later in this article.
- On the File menu, click Properties, and then on the General tab, click
Print Processor.
- In the Default Datatype box, click Text, and then click OK.
- Start Microsoft Word and open the document that you want to print to
a file.
- On the Edit menu, click Select All.
- On the Format menu, click Font. On the Font tab, click Roman (10
characters per inch) in the Font list.
- In the Size list, click 10, and then click OK.
- On the File menu, click Print. Under Printer, select the Print To File
check box, and then click OK.
Installing the Generic / Text Only Printer
To install the Generic / Text Only printer for method 2, follow these
steps:
- Click the Start button, point to Settings, and then click Printers.
- Double-click Add Printer, and then click Next.
- Click Local Printer or Network Printer as appropriate, and then click
Next.
If you click Network Printer, you are prompted for the network path
for the printer. If you do not know the correct path, click Browse, or
check with your network administrator. Click either Yes or No in the
"Do you print from MS-DOS-based programs?" area, and then click Next.
- Under Manufacturers, click Generic. Under Model, click Generic / Text
Only, and then click Next.
- If you chose to install a local printer, click the correct port and
then click Next.
- Type a name for the printer (or accept the default name), and then
click either Yes or No in the "Do you want your Windows-based programs
to use this printer as the default printer?" area. Click Next.
- To print a test page, click Yes. Click Finish.
STATUS
Microsoft has confirmed this to be a problem in the Microsoft products
listed at the beginning of this article. We are researching this problem
and will post new information here in the Microsoft Knowledge Base as it
becomes available.
|