WD97: ODMA Save As Command Does Not Close the Previous Document

Last reviewed: March 20, 1998
Article ID: Q174304
The information in this article applies to:
  • Microsoft Word 97 for Windows
  • Microsoft Word 97 for Windows, Service Release 1

SYMPTOMS

When the Save As command is used to save a Word document with a different file name, you may receive unexpected behavior.

Case 1: If You Are Using a Document Management System (DMS)

If you are using Microsoft Word 97 for Windows with a document management system, after you attempt to open a document, you receive the following error message:

   <original.doc> is being used by another user.
   Do you want to make a copy?

NOTE: <Original.doc> is the name of the file you are trying to open. This error message will be displayed if, before you attempt to open the file, another user has opened <original.doc> and has used the Save As command to save a copy of it. The error message is displayed even if the other user no longer has <original.doc> open in a window.

If you are using a DMS system, you may experience data loss in the original document.

Case 2: If You Are Using GroupWise

When you click Exit on the File menu with a GroupWise document open, you may receive the following error message in Word:

   GroupWise error 8201 - cannot return document to library

CAUSE

This problem occurs because Microsoft Word does not correctly close the original document when you use the Save As command to save the document with another file name.

During the Save As process, Word looks for a drawing object in the document. If the document lacks a drawing object, the document is not closed correctly.

NOTE: Once you quit Microsoft Word or close the newly created document (the document you created using the Save As command with <original.doc>), the original document is closed as expected.

RESOLUTION

Updated Winword.exe and Wwintl32.dll files that resolve this problem are available from Microsoft Technical Support.

If you are running Word in a Document Management System (DMS) environment and require these files, contact Microsoft Technical Support at (425) 462- 9673 and request the files associated with this Knowledge Base article (Q179435).

The ODMAupd.exe file you will receive contains the following files:

   Winword.exe   5,199 KB, 5.07MB(5,323,536 bytes)   1/14/98
   WWintl32.dll  1,131 KB, 1.01MB(1,157,904 bytes)   1/14/98

Although this supported fix is now available, it has not been fully regression-tested and should be applied only to systems experiencing this specific problem.

Note: If you are not running a Document Management System or Groupwise, this

      fix will be of no benefit and should not be installed.

STATUS

Microsoft has confirmed this to be a problem in Word 97 for Windows, and Word 97 for Windows, Service Release 1.

MORE INFORMATION

When you obtain the self-extracting executable file, extract its contents and copy the files to the location in which your Office program files are stored. The default location for Office program files is

   C:\Program Files\Microsoft Office\Office

If you installed Word using the Run From Server option, contact your network administrator to replace the existing Winword.exe and WWintl32.dll files on the server with the new ones supplied by ODMAupd.exe.

Microsoft recommends that you install Office 97 Service Release 1 (SR-1) before installing the Word ODMA update. For more information about installing and obtaining Office 97 SR-1, please see the following articles in the Microsoft Knowledge Base:

   ARTICLE-ID: Q172527
   TITLE     : WD97: How to Obtain Word 97 for Windows Service Release 1

   ARTICLE-ID: Q172475
   TITLE     : OFF97: How to Obtain and Install the MS Office 97 SR-1 Patch

Removing the Saveas.dot Macros

If you previously installed a macro to workaround the problem or if you installed the Saveas.dot template provided by Microsoft Technical Support, you may want to remove the macros.

NOTE: If your version of Word was installed with the Run From Network Server option, contact your network administrator to complete these steps.

To remove the macros, follow these steps:

  1. Open the Normal.dot file.

    By default, this file located in the C:\Program Files\Microsoft Office\Templates folder.

  2. On the Tools menu, point to Macro, and click Macros.

  3. Select the Document_open macro, and then click Delete.

  4. Close Word. If prompted, save the changes to Normal.dot. If you are unable to save the changes to Normal.dot, contact your network administrator.


Additional query words: saveas saveas.dot pcdocs PC DOCS ODMA DMS Missing
edits changes lost corrupt damaged lost lose novell changes lost corrupt
damaged lost lose novell
Keywords : winword word8 word97 kb3rdparty kbnetwork kbfaq
Version : WINDOWS: 97;
Platform : WINDOWS
Hardware : x86
Issue type : kbbug
Solution Type : kbfix kbfile


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Last reviewed: March 20, 1998
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