WD97: Error: "Cannot Access the File" After File Closed (ODMA)

Last reviewed: March 20, 1998
Article ID: Q179435

The information in this article applies to:

  • Microsoft Word 97 for Windows
  • Microsoft Word 97 for Windows, Service Release 1
a DMS

SYMPTOMS

If you are running Word 97 in a Document Management System (DMS) that uses the ODMA API, you may receive the following error message after copying a large amount of text and closing a document:

  • The process cannot access the file because it is being used by another process.

    -or-

  • <document name> is in use by another application.

These error messages will occur when the DMS attempts to move or catalog the original Word document.

CAUSE

This problem occurs because when you use the Cut or Copy commands to copy data, Word makes a copy of the information, saves it in memory, and makes a note of where the copied data is stored (it caches the data). Word incorrectly keeps the pointer to this cached information after allowing the file to be closed. The error message is displayed when the document management system attempts to move or catalog the original Word file.

RESOLUTION

Updated Winword.exe and Wwintl32.dll files that resolve this problem are available from Microsoft Technical Support.

If you are running Word in a Document Management System (DMS) environment and require these files, contact Microsoft Technical Support at (425) 462- 9673 and request the files associated with this Knowledge Base article (Q179435).

The ODMAupd.exe file you will receive contains the following files:

   Winword.exe   5,199 KB, 5.07MB(5,323,536 bytes)   1/14/98
   WWintl32.dll  1,131 KB, 1.01MB(1,157,904 bytes)   1/14/98

NOTE: You can see these file sizes by viewing Details in Windows Explorer. You may see a slightly different size when viewing File Properties.

Although this supported fix is now available, it has not been fully regression-tested and should be applied only to systems experiencing this specific problem. Unless you are severely impacted by this specific problem, Microsoft recommends that you wait for the next Service Pack that contains this fix. Contact Microsoft Technical Support for more information.

Note: If you are not running a Document Management System or Groupwise,

      this fix will be of no benefit and should not be installed.

STATUS

Microsoft has confirmed this to be a problem in Word 97 for Windows, and Word 97 for Windows, Service Release 1.

MORE INFORMATION

When you obtain the self-extracting executable file, extract its contents and copy the files to the location in which your Office program files are stored. The default location for Office program files is

   C:\Program Files\Microsoft Office\Office.

If you installed Word using the Run From Server option, contact your network administrator to replace the existing Winword.exe and WWintl32.dll files on the server with the new ones supplied by ODMAupd.exe.

Microsoft recommends that you install Office 97 Service Release 1 (SR-1) before installing the Word ODMA update. For more information about installing and obtaining the Office 97 SR-1, please see the following articles in the Microsoft Knowledge Base:

   ARTICLE-ID: Q172527
   TITLE     : WD97: How to Obtain Word 97 for Windows Service Release 1

   ARTICLE-ID: Q172475
   TITLE     : OFF97: How to Obtain and Install the MS Office 97 SR-1 Patch

REFERENCES

For additional information, please see the following article in the Microsoft Knowledge Base:

   ARTICLE-ID: Q174304
   TITLE     : WD97: Save As Command Does Not Close the Previous Document

   ARTICLE-ID: Q159963
   TITLE     : WD97: Word 97 Supports ODMA


Additional query words: PCDocs PC Docs groupwise novell saveas saveas.dot
legal
Keywords : word97 kb3rdparty kbinterop
Version : WINDOWS:97
Platform : WINDOWS
Issue type : kbbug
Solution Type : kbfix


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Last reviewed: March 20, 1998
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