Windows Setup Was Unable to Update Your System Files

Last reviewed: March 19, 1998
Article ID: Q125480
********************************************************************
     BETA INFORMATION  BETA INFORMATION  BETA INFORMATION  BETA

     This article discusses a Beta release of a Microsoft
     product. The information in this article is provided as-is
     and is subject to change without notice.

     No formal product support is available from Microsoft for
     this Beta product. For information about obtaining support
     for a Beta release, please see the documentation included
     with the Beta product files, or check the Web location
     from which you downloaded the release.

     BETA INFORMATION  BETA INFORMATION  BETA INFORMATION  BETA
********************************************************************

The information in this article applies to:

  • Microsoft Windows 95
  • Microsoft Windows 98

SYMPTOMS

One of the following symptoms may occur:

  • Windows stops responding (hangs) during Setup, when it attempts to load, or at the End User License Agreement screen.
  • You are asked whether you want to overwrite the boot sector. Choosing Yes may allow you to complete the Setup procedure, but Windows hangs when it attempts to load.
  • The images on the screen become distorted.

After you restart the computer, you receive the following message:

   Windows Setup was unable to update your system files

   This may be caused by virus detection that is built-in to your machine,
   or by virus detection software running on your system.

   To disable built-in virus detection you will need to run the
   configuration program for the CMOS that came with your machine, or
   contact your machine manufacturer.

   To disable virus-detection software that you have running on your
   system, you may need to remove the lines that start the program from
   your AUTOEXEC.BAT or CONFIG.SYS files.

   After you have disabled the virus detection software, re-start your
   machine and re-run Windows Setup. Once you have successfully completed
   setup, it is okay to re-enable the virus detection software.

CAUSE

Some computers include a feature that prevents applications from writing to the boot sector. Such features are normally in the form of anti-virus protection set in your computer's CMOS settings. If anti-virus protection is enabled, Windows cannot complete its installation, or it does not load properly.

RESOLUTION

Disable the anti-virus feature in your computer's CMOS settings, and then reinstall Windows. Once you have successfully installed Windows, re- enable the anti-virus feature.

For information about accessing your computer's CMOS settings, please consult your owner's manual or your computer manufacturer.

NOTE: In order to disable Compaq's SafeStart Manager in the CMOS settings, you must upgrade the BIOS to at least version 2.26b.

MORE INFORMATION

The following computers have been found to display this problem:

  • Acma Pentium 120 computer

        - Award Modular BIOS v4.50G, copyright 1994-1995, Award Software
        - 586 PCI Green BIOS 52xver.A
        - Award BIOS v4.50 3.03G, dated 12.02.93, 84-93 VT82C486A
    
  • NCR 3150 laptop computers with a Phoenix BIOS dated 1993

    These computers have a Boot Sector Protect setting. If this option is enabled, you may receive the following error message at startup:

          Non-system disk or disk error. Replace and strike any key
          when ready.
    

    If you disable this option in the computer's CMOS settings, Windows should start normally.


Additional query words: 95 antivirus locks freezes hang
Keywords : kberrmsg kbsetup diskmem win98 win95 kbfaq
Version : 95
Platform : WINDOWS


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: March 19, 1998
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.