Joystick Port Not Removed When Sound Card Is Removed

Last reviewed: February 11, 1998
Article ID: Q132517
********************************************************************
     BETA INFORMATION  BETA INFORMATION  BETA INFORMATION  BETA

     This article discusses a Beta release of a Microsoft
     product. The information in this article is provided as-is
     and is subject to change without notice.

     No formal product support is available from Microsoft for
     this Beta product. For information about obtaining support
     for a Beta release, please see the documentation included
     with the Beta product files, or check the Web location
     from which you downloaded the release.

     BETA INFORMATION  BETA INFORMATION  BETA INFORMATION  BETA
********************************************************************

The information in this article applies to:

  • Microsoft Windows 95
  • Microsoft Windows 98

SYMPTOMS

When you remove a sound card from your computer and remove the sound card in Device Manager, the joystick (game) port on the sound card still appears in Device Manager.

CAUSE

There is no parent-child relationship between the sound card and the joystick port. Therefore, when you remove the sound card in Device Manager, the joystick port is not automatically removed.

In addition, because the virtual joystick device driver (Vjoyd.vxd) cannot normally detect whether the joystick port has been removed or the joystick port is present but has no joystick attached, the driver is always active. Therefore, when the hardware in your computer is detected, detection is not run on the joystick port.

RESOLUTION

You can manually remove the joystick port in Device Manager by following these steps:

  1. Use the right mouse button to click My Computer, then click Properties on the menu that appears.

  2. Click the Device Manager tab.

  3. Double-click the Sound, Video, And Game Controllers branch to expand it.

  4. Click the joystick port, then click Remove.

STATUS

Microsoft has confirmed this to be a problem in Microsoft Windows 95. We are researching this problem and will post new information here in the Microsoft Knowledge Base as it becomes available.


KBCategory: kbsetup kbenv kbbuglist kbfaq
KBSubcategory: wpp95 win95
Additional reference words: 95
Keywords : wpp95 win98 win95 kbbuglist kbenv kbfaq kbsetup
Version : 95
Platform : WINDOWS


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: February 11, 1998
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.