Problems Accessing CD-ROM with Wrong Version of Mscdex.exe

Last reviewed: March 18, 1998
Article ID: Q139428
95 WINDOWS kbhw

********************************************************************

     BETA INFORMATION  BETA INFORMATION  BETA INFORMATION  BETA

     This article discusses a Beta release of a Microsoft
     product. The information in this article is provided as-is
     and is subject to change without notice.

     No formal product support is available from Microsoft for
     this Beta product. For information about obtaining support
     for a Beta release, please see the documentation included
     with the Beta product files, or check the Web location
     from which you downloaded the release.

     BETA INFORMATION  BETA INFORMATION  BETA INFORMATION  BETA
********************************************************************

The information in this article applies to:

  • Microsoft Windows 98
  • Microsoft Windows 95

SYMPTOMS

When you try to access your CD-ROM drive in Windows 95, you may experience one of the following symptoms:

  • You cannot run executable (.exe) files.
  • You cannot view complete directory listings.
  • You receive the error message "Device not found."

CAUSE

These problems can occur if you are using an older version of Mscdex.exe that is not compatible with Windows 95.

When you install certain real-mode CD-ROM drivers, an older version of Mscdex.exe is copied to the hard disk and a reference to the older version of Mscdex.exe is placed in the Autoexec.bat file.

RESOLUTION

Modify the Autoexec.bat file to reference the correct version of Mscdex.exe. To do so, follow these steps:

  1. Make a backup copy of the Autoexec.bat file.

  2. Use any text editor (such as Notepad) to open the Autoexec.bat file.

  3. Modify the line containing Mscdex.exe to read

          <drive>:\windows\command\mscdex.exe <parameters>
    

    where <drive> is the drive containing Windows 95 and <parameters> are the parameters from the original line containing Mscdex.exe.

    NOTE: To maintain compatibility with the installed CD-ROM driver, make sure to use all the parameters exactly as they are used in the original line.

  4. Save and then close the Autoexec.bat file.

  5. Shut down and restart your computer.


KBCategory: kbhw kberrmsg
KBSubcategory: win95 windrvr
Additional reference words: 95
Keywords : win95 windrvr win98 kberrmsg kbhw
Version : 95
Platform : WINDOWS


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: March 18, 1998
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.