Dot-Matrix Printer Prints Slowly After Upgrade to Windows 95

Last reviewed: March 18, 1998
Article ID: Q148348
3.10 3.11 95 WINDOWS kbprint kbhw

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     This article discusses a Beta release of a Microsoft
     product. The information in this article is provided as-is
     and is subject to change without notice.

     No formal product support is available from Microsoft for
     this Beta product. For information about obtaining support
     for a Beta release, please see the documentation included
     with the Beta product files, or check the Web location
     from which you downloaded the release.

     BETA INFORMATION  BETA INFORMATION  BETA INFORMATION  BETA
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The information in this article applies to:

  • Microsoft Windows 98
  • Microsoft Windows operating system versions 3.1, 3.11
  • Microsoft Windows for Workgroups versions 3.1, 3.11
  • Microsoft Windows 95

SYMPTOMS

After you upgrade to any of the Windows versions listed above, your dot- matrix printer may seem to print slowly. In addition, the printer may no longer print during each pass of the print head. The printer may print only as the print head passes in one direction, not as the print head passes in both directions.

CAUSE

These symptoms can occur for any of the following reasons:

  • The document that you are printing contains TrueType fonts instead of printer fonts. Because TrueType fonts are sent to dot-matrix printers as graphics, they are printed in graphics mode, which is slow. If you were using primarily printer fonts with your previous version of Windows or Windows for Workgroups, and you are using primarily TrueType fonts with your current version of Windows, printing may seem slower.

    NOTE: Some of the printer drivers that are included with Windows 95 do not support printer fonts. When you are using one of these drivers, TrueType fonts are used in place of printer fonts. This may cause your documents to print slowly. If you were using a Windows 3.1 printer driver with your previous version of Windows or Windows for Workgroups, and you are using a printer driver that does not support printer fonts with Windows 95, printing may seem slower.

  • The print resolution, print quality, or printer font that your printer is configured to use is causing it to print only as the print head passes in one direction. Because the printer is no longer printing as the print head passes in both directions, printing may seem slower.
  • If you are using Windows 95, it may be configured to spool print jobs to your computer's hard disk until the printer is ready to print. This allows Windows 95 to return control to the program that you are printing from much faster, but it may cause overall printing speed (the amount of time that it takes for a document to be printed) to seem slower.

RESOLUTION

To work around this problem, use one of the following methods:

  • If the documents that you are printing contain TrueType fonts instead of printer fonts, you may want to use printer fonts in your documents instead of TrueType fonts. Printer fonts appear in font lists with a printer icon next to the font name. TrueType fonts appear in font lists with "TT" next to the font name.

    If printer fonts do not appear in font lists in programs that you print from, you may be using a Windows 95 printer driver that does not support printer fonts. To determine if this is the case, use the Windows 3.1 printer driver included with the printer instead of the printer driver included with Windows 95. For information about installing Windows 3.1 printer drivers in Windows 95, please see the following article in the Microsoft Knowledge Base:

          ARTICLE-ID: Q132946
    
          TITLE     : How to Install Windows 3.1 Drivers in Windows 95
    
    
  • If your printer is printing only as the print head passes in one direction, configure your printer to use a lower print resolution or print quality, or a lower-quality printer font. For example, if your printer is currently configured to print in letter quality (LQ) mode, you may be able work around this problem by configuring it to print in draft mode instead.

    To modify the print resolution or print quality that your printer is configured to use when you are using a printer driver included with Windows 95, double-click the Printers icon in Control Panel, use the right mouse button to click the printer that you want to configure, click Properties, and then click the Graphics tab to modify the print resolution or the Device Options tab to modify the print quality.

    NOTE: Not all dot-matrix printers allow you to configure the print resolution and print quality in this manner. If the Graphics or Device Options tab does not appear on the property sheet for your printer, if you are using the Windows 3.1 printer driver included with the printer instead of the Windows 95 printer driver, or if you want to configure your printer to use a lower-quality printer font, contact the printer's manufacturer for information about configuring your printer.

  • If you are using Windows 95, configure it to print directly to the printer instead of spooling print jobs to your hard disk. Doing so may improve overall printing speed, but it may also increase the amount of time that it takes for Windows 95 to return control to the program you are printing from. To configure Windows 95 to print directly to the printer, follow these steps:

    1. In Control Panel, double-click Printers.

    2. Use the right mouse button to click the printer that you want to

          configure, and then click Properties on the menu that appears.
    

    3. Click the Details tab.

    4. Click Spool Settings, click Print Directly To The Printer, and

          then click OK.
    

    5. Click OK.

MORE INFORMATION

Most dot-matrix printers can be configured for three different print resolutions and three different print qualities. For example, a typical dot-matrix printer may offer 360, 180, and 90 dots per inch (dpi), and letter quality, near letter quality (NLQ), and draft mode. Depending on the printer you are using, certain combinations of print resolution and print quality may cause the printer to print only as the print head passes in one direction. This typically occurs at higher resolutions or at higher print qualities, as the printer attempts to generate higher quality output by gaining more control over placement of the print head.

For example, most dot-matrix printers print only as the print head passes in one direction when they print at 360 dpi in LQ mode. These printers typically print as the print head passes in both directions when they print at 90 dpi in draft mode. When they print using any other combination of print resolution and print quality, some printers may print only as the print head passes in one direction, while others may print as the print head passes in both directions.

In addition, some printers offer both LQ and NLQ printer fonts, and draft printer fonts. When the LQ or NLQ printer fonts are used, the printer typically prints only as the print head passes in one direction. When the draft printer fonts are used, the printer typically prints as the print head passes in both directions.


KBCategory: kbprint kbhw
KBSubcategory: win31 wfwg win95 windrvr winttf
Additional reference words: 3.10 3.11 95 true type
Keywords : wfwg win31 win95 windrvr winttf win98 kbhw kbprint
Version : 3.10 3.11 95
Platform : WINDOWS


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Last reviewed: March 18, 1998
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